Skip to main content

Broken Dashboards and panels in a report of Logi Info



  • Official comment
    Natan Cohen

    Hi Jerry,

    Thanks for posting the full debug page.  The error appears to be in our script evaluator module, and I find that these errors can occur if the script is either invalid or one operand is missing.  For example, if the evaluator tried to execute " > 5", it would throw a server error because the left operand is missing.  One trick to minimize these errors, is to always use double quotes if the operands are strings.  The empty string is never equivalent to null.  This won't work for numeric values with operators like ">" and "<", though.

    To find out which script is causing this error, please load only one panel in your dashboard and try to reproduce the error.  Then look at all the scripts you've declared in your attributes and try to find the script where one or more operands could be null.  Let me know what you find.

    Logi Support

  • Jerry

    Hi Natan,

    Thanks for the reply.

    However, I don't think the scripts are the main problem.

    I just tried on another application thinking perhaps there was a library problem, but the same thing happened! It errors as soon as you add a panel to a dashboard.

    <?xml version="1.0" encoding="utf-8"?>
    <Report ID="Menu.test" SavedBy="user" SavedAt="8/21/2020" EngineVersion="12.7.100-SP1">
        <Dashboard2 ID="Dashboard1" SaveFile="@Function.AppPhysicalPath~\SavedDashboards\testDashboard.xml" DashboardColumns="3" DashboardTabs="True">
          <Panel ID="pnl1" Caption="Panel 1">
              <Label Caption="test" />
      <ideTestParams />
  • Natan Cohen

    Hi Jerry,

    Can you test with a vanilla (blank) Report definition?  First see if you can run the definition with a Dashboard element and no panels.  Then test with a simple panel that outputs a label, like you have above.  If it throws the same error, then please attach the full debug trace.  The fact that you claim that this error is thrown on an entirely separate Logi app may indicate that there is perhaps a masked write permissions error on the dashboard save file location, or perhaps an issue with a .Net dependency library in the GAC.  

    Logi Support


Please sign in to leave a comment.