Logi Info Forum Threads    >    Posts


Logi Debugger Trace Report

Phil Oxenberg
United States

10 Oct 2019 09:43 AM
   
This thread is open for replies.
12.6.114-SP2   Java app   83 views   Subscribe  


Are the Logi Debugger Trace Reports accurate?  I have a compare filter with an Include Condition attribute whose value is: "@ Request.inpDisease~"= "" When I select a disease from my Input Select List and I look in the trace report I see the following for the compare filter:

IncludeCondition: "" != ""

Evaluated False, skipping CompareFilter.

 

My question is, why am I not seeing "Cancer" != ""

Is my syntax incorrect?

 

J. Reitter
United States

14 Oct 2019 08:33 AM

Without seeing the actual definition, I might suggest the following for troubleshooting: 

  1. In the main application, there is a file called "rdPage.aspx". Edit the file and change the "Trace" flag from "False" to "True":  % @ Page Language="vb" Trace="False" %
  2. Put in a label somewhere with "@ Request.inpDisease~" to trace if it receives a value. 
  3. When you are doing the "Input Select List", are you using something to refresh the page or "sections" of your report to accept the updated value? (Event Hander "onchange" with an "Action.RefreshElement"? 
Phil Oxenberg
United States

14 Oct 2019 09:39 AM

Thanks, that's a great idea. 

And yes, my page is being refreshed as described.

So, exactly where will I find the trace?

J. Reitter
United States

16 Oct 2019 03:40 PM

It is not really a "Trace", but it displays additional information at the bottom of each website. We use it to review variables... once you set the flag you will see it.

Phil Oxenberg
United States

16 Oct 2019 03:41 PM

Thank you.



Corporate Headquarters

7900 Westpark Drive, A200
McLean, Virginia 22102 USA
1-888-564-4965
Email US Sales Team


© Copyright 2007-2019 Logi Analytics, Inc. All Rights Reserved           |          Contact DevNet          |          Site FAQs          |          Terms of Use          |          LogiAnalytics.com